Archived cra cra Crash!!??

Discussion in 'Support' started by joni909, Feb 17, 2017.

  1. joni909

    joni909 New Member

    so i started testing this game but came to the loading bar after you made a world then it crashed


    ("i have a Windows Machine with win10")

    Attached Files:

  2. joni909

    joni909 New Member

    side note

    i tested multiplayer and that worked
    but it crashes in SP while i tried to make a world with only core componenets
  3. Cervator

    Cervator Project Lead and Community Wizard Staff Member

    Hi there thanks for the bug report :)

    I saw the same error (java.lang.NoClassDefFoundError: org/terasology/world/generation/facets/SurfaceDepthFacet) get reported on IRC the other day, was that you by chance?

    That error usually comes about from modules building out of order, or version mismatches between modules and/or the engine.

    As per the logs you're using the latest stable release, Alpha 6, but by chance did you update some of the modules, like via in-game module browser?

    If you updated modules that way it could explain why local single player fails (using the updated modules) yet multiplayer against a server works (the server determines which module versions to use)
  4. Kawaii Bang

    Kawaii Bang New Member

    this also happened to me :( I'm upset because, when I finished downloading the game, it did not pop up in the homescreen of my laptop like the other games I download would, and when I pressed the right arrow button, it was loading and ready for me to play, it finished loading and suddenly crashed. please help! :/
  5. Cervator

    Cervator Project Lead and Community Wizard Staff Member

    Hi @Kawaii Bang - it helps to make a whole new thread unless you're absolutely sure your situation matches, providing log files to indicate as much. There are many ways in which the game can crash :)

    For instance the above issue is likely resolved in newer builds as I went through our build server and gave it a thorough cleanup that should help avoid such build errors. However, laptops most usually fail to run the game due to weaker video cards.

    What exact symptoms did you encounter and could you provide the log files from your system? It sounds like you were also using the launcher, which is also different. Which version of the game did you download and run?
  6. Kawaii Bang

    Kawaii Bang New Member

    I just went on terasology.org and pressed download. Then I clicked launcher. It sent me to the website where I'm supposed to download the launcher. I downloaded the latest version that time :/
    Last edited: Apr 23, 2017
  7. Cervator

    Cervator Project Lead and Community Wizard Staff Member

    Hey again - I'm out of town but nearly back home. Did you have any luck redownloading? Noticed in the other thread.

    We really need more details (log files) to have a chance to help diagnosing the issue ... :)

    If you haven't tried the game itself yet perhaps give the direct game download a try

Share This Page