Link to game from Linux Game Database

Discussion in 'Destination Sol' started by AvaLanCS, Aug 22, 2016.

  1. AvaLanCS

    AvaLanCS Member

    Hi Everyone!

    I found the game 2 days ago on Linux Game Database: https://lgdb.org/game/destination-sol

    I am absolutely in love with it, but on that page it links to sourceforge, which has an older version of the game. Maybe someone could contact that page, and tell them to link to github instead?

    p.s.: The readme in the source does not have instructions for eclipse, but importing works for me without a problem on linux.
  2. Cervator

    Cervator Project Lead and Community Wizard Staff Member

    That entry was created by Milosh, the original dev from the old team. I still have contact info so I'll try to email him and see if he can give us access so we can update it. Thanks for the link and welcome! :)

    Did you have to do anything at all on Eclipse, like create a way to run the game from the project? If you have any tips or details that may help feel free to submit a pull request on GitHub to update the readme
  3. AvaLanCS

    AvaLanCS Member

    I was a bit hasty with eclipse, sorry.

    So I was doing it from my laptop with XUbuntu. Running "gradlew run" in the source folder was working. Creating a java project over it, and starting the class for the desktop edition worked fine. Then I made this post, and re-read the readme, and noticed it should be run as a gradle project.
    This was my first time with gradle, so I downloaded one of the gradle plugins to eclipse, and tried to import the project again. It turned into 3 projects, and the plugin kept crashing eclipse again and again, so I had to remove the plugin. When I have some more time I'll try the same on windows, just to be sure if the problem is with the plugin, or just me using an exotic linux distro.

    If the plugin would not work; do you think modifying the source as a java project, then running gradle from the terminal from that folder would okay? I mean I am worried it would run fine on my machine, then ruin the build on jenkins.
  4. Cervator

    Cervator Project Lead and Community Wizard Staff Member

    Chances are we don't have the Eclipse tweaks correctly configured in Gradle yet. There are blocks for setting up the project in IntelliJ, which is what most of us use. Chances are we can add a few tweaks that'll be unique to Eclipse setup and won't affect IntelliJ or Jenkins at all. Same thing in Terasology :)

    Coincidentally an update to the Terasology side was just updated, just to give you an idea of how that works: https://github.com/MovingBlocks/Terasology/pull/2455

    I don't recall for sure but you might simply be the first person in recent memory to run out of Eclipse. However, my recent memory has distinct heap size limits so I might just be misremembering and somebody else knows how to make it work :D
  5. AvaLanCS

    AvaLanCS Member

    Haha, thank you!
    • Like Like x 1

Share This Page