Problem package org.terasology.protobuf.NetData does not exist


New Member

can somebody help me. If I run TerasologyPC on Intellij I receive 2 problem messages: 'packages org.terasology.protobuf does not exist' and ' package NetData does not exist'. I installed protobuf on Linux Mint 20.2 with the command 'sudo apt install protobuf-compiler'. But I still get the same problems as before.
What can I do?

I appreciate any hints you might have.

All the Best, Else


Org Co-Founder & Project Lead
Hey there, apologies for the delayed response.

We adjusted the way protobuf works a while ago, it should all be handled automatically through Gradle, but if you had old workspace state you might need to clean and refresh the workspace (gradlew clean jar game should be one way to test). There should be no need to have an actual copy of protobuf installed at the OS level, the needed bits ship with the source code.

Our forum is fairly neglected in favor of Discord, so you'd have an easier time getting support over there more quickly :)