Question The game launches and loads fine but when i play i get like 7 FPS, what can i do to fix this?

manu3d

Active Member
Contributor
Architecture
#2
VizzraN, given your system Terasology should run at a very high FPS. I have much less powerful laptop and I average 30fps in HD resolution.

What's your ViewDistance setting, in the video setting menu? The highest settings are known to give trouble even to powerful systems. You might want to lower it to "Moderate" and then try and the next step up.

I also notice from the log that you are running Terasology through a 32bit JVM (Java Virtual Machine). As you have a 64bit system you should really run Terasology via the 64bit JVM.

I hope this helps.

Kind regards, Manu
 
#3
VizzraN, given your system Terasology should run at a very high FPS. I have much less powerful laptop and I average 30fps in HD resolution.

What's your ViewDistance setting, in the video setting menu? The highest settings are known to give trouble even to powerful systems. You might want to lower it to "Moderate" and then try and the next step up.

I also notice from the log that you are running Terasology through a 32bit JVM (Java Virtual Machine). As you have a 64bit system you should really run Terasology via the 64bit JVM.

I hope this helps.

Kind regards, Manu
I have all my settings on low, screenshots will be attached. This is a stupid question but how do i run it with 64 bit and not 32 bit?
 

Attachments

Cervator

Org Co-Founder & Project Lead
Contributor
Design
Logistics
SpecOps
#4
Hey @VizzraN - to run with a 64-bit Java you need to install one. If you go to http://www.oracle.com/technetwork/java/javase/downloads/jre8-downloads-2133155.html you should see both x86 (32-bit) and x64 (64-bit ... yeah fun naming). Make sure you have a 64-bit installed.

After that point either that one note in the game log about running a 32-bit should go away or you can verify in a command prompt with "java -version" - it should return "64-Bit Server VM" in there somewhere. If it doesn't then your system is defaulting to the 32-bit likely because of your PATH environmental variable. You need the bin directory of the 64-bit Java to be the only Java in PATH or at least come before the other one. Dunno if you're comfortable tweaking at that, Google is your friend and you can ask for more details here if you like :)

Did you try other gameplay templates? If the lag only occurs with MedievalCities but not Core or JoshariasSurvival then that's critical info to know. While in-game you can also press F3 then F4 to get some performance monitors. See what the top few categories are and if one is vastly worse than the others. There should also be some memory stats. You could take a screenshot with the text visible and show that here as well.