I dont' want to rename "src/main" and "src/test". This is also the standard of gradle (not only Maven).
"main" should only contain the files for the application/applet
"test" should only contain Unit-Tests (like JUnit)
"perfTest" conatins at the moment only one (long running) performance test.
I think we need another folder (=> a gradle SourceSet). This folder can contain java classes with a main method.
We can use this classes during development.
Examples:
1. The existing performance test.
2. A class which generates a large world (many chunks) with a WorldGenerator.
3. A class which analyses the generated worlds (statistics)
4. A class which creates maps (overview, height map, ...) from the generated worlds.
I don't want to put these classes into "main", "test" or "perfTest". So I think we need a new name.
Suggestions:
manual
development or dev
adhoc
additional or addition
Any more?
Immortius: I changed the performance test last week. IntelliJ should not run it after start/import.