Rename "perfTest"

mkalb

Active Member
Contributor
Logistics
I would like to rename the folder "perfTest". At the moment we have the subfolders "main", "test" and "perfTest".

I think we need a folder for development and manual tests.

But I am not sure about the new name.
"src/development"
"src/manual"
...
Any suggestions?

Mathias
 

Immortius

Lead Software Architect
Contributor
Architecture
GUI
I think "src/test" should remain as "src/test" in keeping with the standard (I realise we are not using Maven, but it is still a nice, well understood structure so I feel we should keep to it). You could rename "src/perfTest" to "src/performanceTest" or "src/benchmark" if you feel that adds clarity. We don't actually have manual tests, just performance tests which can be run separately (but still in an automated fashion). But I know I am splitting hairs there.
 

Cervator

Org Co-Founder & Project Lead
Contributor
Design
Logistics
SpecOps
src/adhoc (or adhocTest) ?
 

x3ro

Member
Contributor
GUI
Okay, maybe I'm missing something here, but why not "src/test/performance" ? :)
 

Cervator

Org Co-Founder & Project Lead
Contributor
Design
Logistics
SpecOps
Okay, maybe I'm missing something here, but why not "src/test/performance" ? :)
Probably src/test is meant to run every build as unit tests. Performance tests might be lengthy, so they should ideally run separately.

Maybe a way to make that work even under src/test/performance though, dunno!

"adhoc" was my thinking of also putting other weird things under there, if ever needed (maybe not)
 

Immortius

Lead Software Architect
Contributor
Architecture
GUI
Yeah, the one performance test we have took about 5 minutes to run. I don't want that mixed up with the other unit tests. That said IntelliJ tends to run it anyway so I modified that scale of the test down at some point.
 

mkalb

Active Member
Contributor
Logistics
I dont' want to rename "src/main" and "src/test". This is also the standard of gradle (not only Maven).

"main" should only contain the files for the application/applet
"test" should only contain Unit-Tests (like JUnit)

"perfTest" conatins at the moment only one (long running) performance test.

I think we need another folder (=> a gradle SourceSet). This folder can contain java classes with a main method.
We can use this classes during development.

Examples:
1. The existing performance test.
2. A class which generates a large world (many chunks) with a WorldGenerator.
3. A class which analyses the generated worlds (statistics)
4. A class which creates maps (overview, height map, ...) from the generated worlds.


I don't want to put these classes into "main", "test" or "perfTest". So I think we need a new name.

Suggestions:
manual
development or dev
adhoc
additional or addition

Any more?

Immortius: I changed the performance test last week. IntelliJ should not run it after start/import.
 

Immortius

Lead Software Architect
Contributor
Architecture
GUI
Ah, ok. I understand now, makes sense.

Suggestions:
demos
standalone
utilities

I'll leave it to your judgement.
 

mkalb

Active Member
Contributor
Logistics
I renamed it into "dev" (short for development).

It is short like "main" and "test" and starts with an other character.
 
Top